Рекомендации по настройке

1. Настройка L2 оборудования

При подключении к RED-IX с использованием L2-оборудования (коммутатора), необходимо убедиться, что в порт RED-IX попадает только тот трафик, который соответствует Техническим Условиям сети RED-IX. Рекомендуется выделить порт подключения к RED-IX в отдельный VLAN.

Пример настройки коммутаторов на базе Cisco IOS:

! На коммутаторах серии 29xx, 35xx, 3750 отключите протоколы VTP, LLDP и UDLD
vtp mode transparent
!
no spanning-tree vlan 400
! Если вы не используете LLDP, отключите глобально
no lldp run
! Если вы не используете CDP, отключите глобально
no cdp run
!
vlan 400
  name RED-IX
!
interface /IfIdent/
  description Interface to RED-IX
  switchport access vlan 400
  switchport mode access
  switchport nonegotiate
  no keepalive
  speed auto
  duplex auto
  no udld enable
  no cdp enable
  no lldp receive
  no lldp transmit
  spanning-tree portfast
  spanning-tree bpdufilter enable
end

2. Настройка Link Aggregation

Режим работы агрегированного линка - принудительно включен (on). Протоколы LACP и PAgP не поддерживаются.

Пример настройки для Cisco Catalyst 6500 Series:

interface GigabitEthernet1/1
  description RED-IX Link 1
  no ip address
  no ip redirects
  no ip proxy-arp
  no keepalive
  no cdp enable
  channel-group 1 mode on
!
interface GigabitEthernet1/2
  description RED-IX Link 2
  no ip address
  no ip redirects
  no ip proxy-arp
  no keepalive
  no cdp enable
  channel-group 1 mode on
!
interface Port-channel1
  description RED-IX aggregated link
  ip address 185.1.13.x 255.255.255.0
  no ip redirects
  no ip proxy-arp
  no keepalive
!

3. Настройка L3 оборудования

Наиболее предпочтительным вариантом подключение к сети RED-IX является использование L3 оборудования (маршрутизатора). В данном случае исключено попадание в порт подключения к сети RED-IX нежелательных MAC-адресов и трафика link-local протоколов (например, STP).

Пример настройки оборудования на базе Cisco IOS:

! Отключите DHCP server/relay
no service dhcp
! На старых версиях IOS требуется такая команда вместо предыдущей
no ip bootp server
! Do not download configs through TFTP
no service config
! Отключите CDP
no cdp run

! Отключите возможность перенаправлять пакеты
no ip redirects
! На интерфейсе в RED-IX отключите proxy ARP
no ip proxy-arp
! На интерфейсе в RED-IX отключите CDP, если не отключен глобально
no cdp enable
! Отключите ip directed-broadcast
no ip directed-broadcast
! Отключите MOP сервис. Используется для работы с DECNet.
no mop enable
! На интерфейсе возможно использование автосогласование скорости и дуплекса
speed auto
duplex auto
! В некоторых версиях IOS возможно ограничивать скорости автосогласования
speed auto 100
duplex auto
! На интерфейсе в RED-IX отключите посылку L2 keepalive пакетов.
no keepalive

4. Настройка протокола BGP

Пример настройки оборудования на базе Cisco IOS, а также ПО Quagga, Zebra для использования услуги RS.

! Создайте prefix-list с перечнем анонсируемых RS сетей
ip prefix-list TO-RED-IX seq 5 permit x.x.x.x/y
ip prefix-list TO-RED-IX seq 10 permit xx.xx.xx.xx/yy
!
route-map RED-IX-EXPORT permit 10
  match ip address prefix-list TO-RED-IX
!
route-map RED-IX-EXPORT deny 65535
!
router bgp ASXXX
  no bgp enforce-first-as
  no synchronization
  bgp router-id 185.1.13.x
  network x.x.x.x mask y.y.y.y
  network xx.xx.xx.xx mask yy.yy.yy.yy
!
  neighbor 185.1.13.1 remote-as 60430
  neighbor 185.1.13.1 version 4
  neighbor 185.1.13.1 next-hop-self
  neighbor 185.1.13.1 route-map RED-IX-EXPORT out
  neighbor 185.1.13.2 remote-as 60430
  neighbor 185.1.13.2 version 4
  neighbor 185.1.13.2 next-hop-self
  neighbor 185.1.13.2 route-map RED-IX-EXPORT out

ASXXX - Номер автономной системы Участника.
185.1.13.x - IP адрес выделенный администрацией RED-IX.
network x.x.x.x mask y.y.y.y
network xx.xx.xx.xx mask yy.yy.yy.yy
В команде network указываются сети, доступные с маршрутизатора Участника, которые будут анонсироваться RS.

5. Использование BGP community

Пример конфигурации для оборудования на базе Cisco IOS, а также ПО Quagga, Zebra:

! Выберете режим отображения community в виде AA:NN
ip bgp-community new-format

! Создайте prefix-list с перечнем анонсируемых RS сетей
ip prefix-list TO-RED-IX seq 5 permit x.x.x.x/y
ip prefix-list TO-RED-IX seq 10 permit xx.xx.xx.xx/yy

! Создайте route-map в котором на анонсируемые префиксы назначается атрибут community
route-map RED-IX-EXPORT permit 10
  match ip address prefix-list TO-RED-IX
! Указываем community
! 0:peer-as - не анонсировать префикс участнику с номером AS peer-as
! 60430:peer-as - анонс префикса участнику с номером AS peer-as
! 0:60430 - запрет на анонс префикса всем участникам
  set community 0:peer-as
!
route-map RED-IX-EXPORT deny 65535

! Включите возможность отправки community маршрутизатором.
! Примените route-map.
router bgp ASXXX
  neighbor 185.1.13.1 send-community
  neighbor 185.1.13.1 route-map RED-IX-EXPORT out
  neighbor 185.1.13.2 send-community
  neighbor 185.1.13.2 route-map RED-IX-EXPORT out
 
   
• вверх • Услуги      • Дата-центр      • Участники RED-IX      • Looking Glass
© 2006-2015, ООО «Вебра», Intertax Group.